port-channel分为2类.一类为2层的port-channel.一类为3层的port-channel. 2层的port-channel只需要配physical interface就行了,可以是static access,也可以是trunk,但是必须一样。不需要create port-channel。
3层的port-channel要首先create port-channel,然后no switchport把port-channel变成L3 interface,加上IP地址。再进入physical interface,必须no ip address去掉physical interface的IP信息,然后直接channel-group加入EtherChannel就行了
example:
For L2 static access EtherChannel:
Switch# configure terminal
Switch(config)# interface range gigabitethernet0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end
For L2 trunk EtherChannel:
Switch# configure terminal
Switch(config)# interface range gigabitethernet0/1 -2
Switch(config-if-range)# switchport trunk encapsulation isl
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end
For L3 EtherChannel:
Switch# configure terminal
Switch(config)# interface port-channel 5
Switch(config-if)# no switchport
Switch(config-if)# ip address 172.10.20.10 255.255.255.0
Switch(config-if)# interface range gigabitethernet0/1 -2
Switch(config-if-range)# no ip address
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end
转载于:https://blog.51cto.com/sgs123/1983819