Identity Card

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4378    Accepted Submission(s): 1355

Problem Description

Do you own an ID card?You must have a identity card number in your family’s Household Register. From the ID card you can get specific  personal  information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it.
Here is the codes which represent the region you are in.

However,in your card,maybe only 33 appears,0000 is replaced by other numbers.
Here is Samuel’s ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).
Input

Input will contain 2 parts:
A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.
Output

Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.
Sample Input
1
330000198910120036
Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
题目大意
       给定多组身份证号码,根据身份证号码的数据信息来判断这个人的所在地省份和其出生日期。
解题思路
       将身份证号码当成字符存入数组,然后选择判断。
       一开始我是将身份证号码当成18个数字存的,这样的话输入身份证号码系统只会认为其为第一个数字,如果当成18个数字存的时候,在输入的时候每个数字之间必须有空格将其分开,很明显不符合题意。
代码
#include<stdio.h>
char s[20];
int province(char a,char b)
{
	if(a=='3'&&b=='3')
	    return 1;
	else if(a=='1'&&b=='1')
	    return 2;
	else if(a=='7'&&b=='1')
	    return 3;
	else if(a=='8'&&b=='1')
	    return 4;
	else if(a=='8'&&b=='2')
	    return 5;
	else if(a=='5'&&b=='4')
	    return 6;
	else if(a=='2'&&b=='1')
	    return 7;
	else if(a=='3'&&b=='1')
	    return 8;
}
int main()
{
	int t;
	int i,j;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		scanf("%s",s);
		switch(province(s[0],s[1]))
		{
			case 1:printf("He/She is from Zhejiang,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",s[10],s[11],s[12],s[13],s[6],s[7],s[8],s[9]);break;
			case 2:printf("He/She is from Beijing,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",s[10],s[11],s[12],s[13],s[6],s[7],s[8],s[9]);break;
			case 3:printf("He/She is from Taiwan,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",s[10],s[11],s[12],s[13],s[6],s[7],s[8],s[9]);break;
			case 4:printf("He/She is from Hong Kong,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",s[10],s[11],s[12],s[13],s[6],s[7],s[8],s[9]);break;
			case 5:printf("He/She is from Macao,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",s[10],s[11],s[12],s[13],s[6],s[7],s[8],s[9]);break;
			case 6:printf("He/She is from Tibet,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",s[10],s[11],s[12],s[13],s[6],s[7],s[8],s[9]);break;
			case 7:printf("He/She is from Liaoning,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",s[10],s[11],s[12],s[13],s[6],s[7],s[8],s[9]);break;
			case 8:printf("He/She is from Shanghai,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",s[10],s[11],s[12],s[13],s[6],s[7],s[8],s[9]);break;
		}
	}
	return 0;
}

 

版权声明:本文为wangluoershixiong原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
原文链接:https://blog.csdn.net/wangluoershixiong/article/details/39448941